Centos7 安装zipArchive及libzip 版本更新

内容为两个问题解决方案:

Centos7安装PHP7 zipArchive支持

configure: error: system libzip must be upgraded to version >= 0.11

环境:Centos7+lnmp+^^^

问题说明:

要使用PHP的zipArchive首先你得安装zip,安装zip你首先又得安装libzip,然后libzip的版本要求是>= 0.11,于是,下面解决。

安装libzip

既然说你的版本低了,那首先肯定得卸载现在的低版本:

然后找个目录下载安装新版本:

截止到今天,最新版本就是1.2.0了,具体可看官方去:https://nih.at/libzip/index.html

安装zip

上面的注意路径问题,路径不对肯定报错,具体看你的环境。同时zip版本可到官方看:http://pecl.php.net/package/zip

修改php.ini

最后,重启php-fpm,结束!