Firefox CSS选择器跨域信息泄露漏洞

发布时间:2010-07-21
影响版本:

Mozilla Firefox 3.6.x
Mozilla Firefox 3.5.x
Mozilla Thunderbird 3.1.x
Mozilla Thunderbird 3.0.x
Mozilla SeaMonkey < 2.0.6

漏洞描述:

Firefox是一款流行的开源WEB浏览器。

如果攻击者能够向目标页的A和B两点之间注入CSS选择器的开放和关闭部分,用户就可以通过getComputedStyle() API读取两个注入点之间的部分。

安全建议:

厂商补丁:

Mozilla
-------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.mozilla.org/

RedHat
------
RedHat已经为此发布了一个安全公告(RHSA-2010:0547-01)以及相应补丁:
RHSA-2010:0547-01:Critical: firefox security update
链接:https://www.redhat.com/support/errata/RHSA-2010-0547.html