Wiki Web Help 0.2.7 cross site scripting

发布时间:2010-07-01
测试方法:

本站提供程序(方法)可能带有攻击性,仅供安全研究与教学之用,风险自负!

------------------------------------------------------------------------
Software................Wiki Web Help 0.2.7
Vulnerability...........Persistent/Reflected XSS
Download................http://sourceforge.net/projects/wwh/
Release Date............7/1/2010
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................John Leitch
Site....................http://cross-site-scripting.blogspot.com/
Email...................john.leitch5@gmail.com
------------------------------------------------------------------------

--Description--

Several XSS vulnerabilities in Wiki Web Help 0.2.7 can be exploited to
execute arbitrary JavaScript.

--Exploit--

Persistent: Event attributes are not removed from user submitted HTML
elements.

Reflected: The rev query string field of revert.php does not HTML
encode user submitted data.

--PoC--

Persistent:

Reflected:
http://localhost/wwh/revert.php?rev=%3Cscript%3Ealert(0)%3C/script%3E