十九楼某站内部系统弱口令多个(附测试脚本)

漏洞概要

缺陷编号:WooYun-2015-0124465

漏洞标题:十九楼某站内部系统弱口令多个(附测试脚本)

相关厂商:十九楼

漏洞作者:盖世

提交时间:2015-07-04 12:20

公开时间:2015-08-18 12:48

漏洞类型:后台弱口令

危害等级:中

自评Rank:10

漏洞状态:厂商已经确认

Tags标签:

漏洞详情

披露状态:

2015-07-04: 细节已通知厂商并且等待厂商处理中
2015-07-04: 厂商已经确认,细节仅向厂商公开
2015-07-14: 细节向核心白帽子及相关领域专家公开
2015-07-24: 细节向普通白帽子公开
2015-08-03: 细节向实习白帽子公开
2015-08-18: 细节向公众公开

简要描述:

十九楼某站内部系统弱口令多个(附测试脚本)

详细说明:

漏洞系统http://blog.19ued.com/使用的是WordPress的博客系统根据WP的缺陷可以遍历用户名我们就http://blog.19ued.com/?author=1...http://blog.19ued.com/?author=100为了快速遍历,就为这个wp系统写了一个简单的抓取用户的脚本

测试截图

得到的用户名

本来爆破也写了脚本的,不过由于有比较好用的burpsuite就用这个工具吧http://blog.19ued.com/wp-login.php 后台爆破得到用户名和密码

登陆一下,发现做了403限制,那么我们从首页在进入后台就可以了利用zhanlijun/123456登陆发现管理员权限

虽然是管理员权限,上传目录都做了不能写入的权限,没法上传那shell了,但是模板编辑处也没有修改的权限,真是日了狗了,还没有想到其他拿shell的方式,就到这里吧。

漏洞证明:

漏洞证明

修复方案:

漏洞回应

厂商回应:

危害等级:中

漏洞Rank:6

确认时间:2015-07-0412:47

厂商回复:

感谢楼主提交。经查发现确实有一些弱密码存在。

最新状态:

暂无

评价

  1. 2010-01-01 00:00 BeenQuiver 白帽子 | Rank:50 漏洞数:6)

    小脚本