当当网过滤不完全导致XSS持久跨站脚本攻击

漏洞概要

缺陷编号:WooYun-2012-016530

漏洞标题:当当网过滤不完全导致XSS持久跨站脚本攻击

相关厂商:当当网

漏洞作者:1ee

提交时间:2012-12-27 14:52

公开时间:2013-02-10 14:53

漏洞类型:XSS 跨站脚本攻击

危害等级:中

自评Rank:10

漏洞状态:厂商已经确认

Tags标签:

漏洞详情

披露状态:

2012-12-27: 细节已通知厂商并且等待厂商处理中
2012-12-27: 厂商已经确认,细节仅向厂商公开
2013-01-06: 细节向核心白帽子及相关领域专家公开
2013-01-16: 细节向普通白帽子公开
2013-01-26: 细节向实习白帽子公开
2013-02-10: 细节向公众公开

简要描述:

~~ 还是过滤不完全导致的...

详细说明:

bypass xss filter代码实现为:

然后当别人查看我的个人空间的时候,看出现什么了

漏洞证明:

还有一些地方就没试了...

修复方案:

漏洞回应

厂商回应:

危害等级:低

漏洞Rank:5

确认时间:2012-12-27 17:02

厂商回复:

感谢提交!

最新状态:

2013-01-11:我们已经修复。感谢洞主对我们的帮助。

评价