The iOS Simulator deployment target is set to 4.3解决

  • 发表于
  • flutter

在ios模拟器上调试的时候出现错误信息:The iOS Simulator deployment target is set to 4.3...

原来是因为ios 版本问题,于是找到资料是在 Podfile文件中添加判断

接着又报错,Using new build systemnote: Planning buildnote

查资料原来是要升级 cocospod,于是百度了下,

1. 检测gem版本

如果gem版本小于2.6.x,则需要更新gem

2. 更新gem(gem版本高于2.6.x可跳过此步)

  1. 检测ruby源,更新gem需要官方的ruby源
  1. 替换ruby源为官方地址(如果ruby源是"https://rubygems.org/"则跳过此步)
  1. 确保ruby源中只有"https://rubygems.org/"
  1. 更新gem(此步要翻墙)
  1. 查看gem版本,确认大于2.6.x
  1. 将ruby源切换回国内的
  1. 确保只有"https://gems.ruby-china.com/"一个ruby源

3. 更新cocoapods


结果还是不行

xcode报错:

android也报错,最后看有人说是因为版本问题,建议换个插件。

目前使用的插件是:

标签:
  • N/A