Error launching app. Try launching from within Xcode via解决

  • 发表于
  • flutter

ios真机

原因:flutter 里面支持调试的iOS版本低于真机的版本

解决方法

更新ios-deploy(推荐)

我们只需要更新 ios-deploy 目录的 ios-deploy 就可以解决这个问题。

1、ios-deploy地址:https://github.com/ios-control/ios-deploy/,下载releases最新的Source code(zip)并解压,运行ios-deploy.xcodeproj工程,选中ios-deploy跟My Mac,注意此时的产品目录下的ios-deploy还是红色的,是没有的,然后跑一下,就会生成一个ios-deploy程式。

Error launching app. Try launching from within Xcode via解决

2、产品目录里面的ios-deploy点选珍选在Finder中显示,跳到资料夹目录

3、手动 ios-deploy 程序打开 flutter SDK 目录的 ios-depoly 里面替换到原来的

4、最后重启vs code,就是你写专案的应用程序,就可以使用低版本的flutter,跑最新版的Xcode了。

升级flutter版本

直接升级flutter版本一般不建议,根据自身情况选择

标签: