ERROR: Could not find a valid gem ‘bundler’ (>= 0)解决方法

问题描述

系统macOS,需要用到ruby gem,执行gem install bundler后报错:

原因是https://ruby.taobao.org/的RubyGems镜像已经不再维护了,需要更换Gem Source,这里我们直接换成Ruby China 镜像。

更换RubyGems镜像源

请尽可能用比较新的 RubyGems 版本,建议2.6.x以上。

这时候再执行gem install bundler顺利完成,若提示权限带上sudo。

ERROR:  Could not find a valid gem 'bundler' (>= 0)解决方法
标签: , , ,