中国蚁剑antSword RCE漏洞,建议所有用户升级

  • 发表于
  • Vulndb
  • 227 阅读

4月12日凌晨,有用户在中国蚁剑GitHub上提交了issue,称发现中国蚁剑存在XSS漏洞,借此可引起RCE。据悉,该漏洞是因为在webshell远程连接失败时,中国蚁剑会返回错误信息,但因为使用的是html解析,导致xss漏洞。

当通过中国蚁剑连接webshell,出现连接失败情况时,中国蚁剑会返回错误信息,如下图:

中国蚁剑antSword RCE漏洞,建议所有用户升级

而该信息并没有进行 XSS 保护,因此能够利用 js 调用 perl 便可反弹攻击者的shell。

中国蚁剑antSword RCE漏洞,建议所有用户升级

反弹shell的exp (for perl)如下,使用base64编码:

base64_decode code

成功反弹攻击者shell:

中国蚁剑antSword RCE漏洞,建议所有用户升级

在该漏洞问题被提出之后,中国蚁剑的作者在今天上午对该问题及时做出了响应,并且及时发布了中国蚁剑的新版本 AntSword v2.0.7.1

中国蚁剑antSword RCE漏洞,建议所有用户升级

在最新的版本中,为了防止插件中 toastr 出现类似问题, 修改了 toastr 可以输出 html 的特点,以后均不支持输出 html。对于所有使用中国蚁剑旧版本的用户,建议及时更新到最新版本。

标签: